コンパイル

前提条件

コンパイル方法

適当に保存用のディレクトリを作る

$ mkdir tmp
$ cd tmp

ソースを取得する

$ git clone git://git.sourceforge.jp/gitroot/hengband/hengband.git .

正常に取得できたか確認してみる。

$ ls
Hengband_vcs2008       autopick.txt      doxygen        readme_angband
Hengband_vcs2010       autopick_eng.txt  hengband.spec  readme_eng.txt
Makefile.am            bootstrap         lib            src
acinclude.m4           configure.ac      readme.txt

make

おまじない。

$ ./bootstrap
+ aclocal
+ autoheader
+ automake --foreign --add-missing --copy
configure.in:6: installing './install-sh'
configure.in:6: installing './missing'
src/Makefile.am: installing './depcomp'
+ autoconf

もう一丁おまじない。

$ ./configure

errorっぽいメッセージが出ずに終了したら成功。 最後にmake

$ make install

これもerrorっぽいメッセージが出ずに終了したら成功。

起動

$ ./hengband -uhoge

こんなエラーが出たんだけど(FAQ)

スパムに捕まったので凍結します。質問はtwitterの@dis_またはdis.rogue@gmail.comまで。

2.1.4のコンパイル

(2013-07-27 (土) 14:48:48)

./configureまではエラーらしいメッセージなし
make installで以下のエラー

Making install in src
gcc -DHAVE_CONFIG_H -I. -I/opt/local/include -g -O2 -fno-strength-reduce -MT z-term.o -MD -MP -MF .deps/z-term.Tpo -c -o z-term.o z-term.c
In file included from angband.h:46,

                from z-term.c:12:

externs.h:1612: error: conflicting types for 'usleep'
/usr/include/unistd.h:507: error: previous declaration of 'usleep' was here
make[1]: *** [z-term.o] Error 1
make: *** [install-recursive] Error 1


新しいバージョンにしたい

(2013-07-24 (水) 22:50:44)

どうすればいいの?


無題

(2013-01-06 (日) 11:39:56)

dump出力したはずなのに見あたらないんだけど


フォントの指定どうやるの?

(2013-01-04 (金) 11:55:47)

日本語になりません



トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS